No refresh token error for Shopify OAuth2


I am having issues with a Shopify custom app and OAuth2.

I can get it connected but when I try to run a query on an endpoint, ‘/admin/api/2021-01/products/count.json’ - I get the error “No refresh token”.

Here is an image of the setup. All the urls look ok to me,

Any pointers or obvious stuff that I might be missing?

We are hoping to use this to update / retrieve the Shopify product meta data and so the normal private app might not be the best way to do this. Otherwise we would use the nodes that have been created already :slight_smile:


Welcome to the community @rm_dev!

Did it never work? If it worked before does reauthenticating solve the problem?

Normal do services return a refresh-token when authenticated the first time. But not all. Is quite possible that Shopify does not. If their access-token never expires that would for example not be needed. So theoretically that problem should never happen as the refresh-token only gets used if the access-token is not valid anymore. The only thing I can think of right now is that the access token got invalidated somehow (like via their UI). Can you think of anything that could have done that?


Thanks for the reply.

Unfortunately, it never worked. I have reset and re-input the credentials and recreated the app on the Shopify side. On first run it errors with ‘No Refresh Token’.

It is a bit odd, as we have other OAuth2 connections working via the HttpRequest Node (Zoho for example).

Anything else I can check?

Thanks again!

So just to understand you correctly. You can authenticate via OAuth2? So the window opens fine and you can confirm? Or does also that already cause problems?

Hey Jan!

It seems that it authenticates fine. The window pops up and I can press the accept button. n8n seems to think it is connected, but when an action is executed it throws the No Refresh Token error.