Notion Trigger issues

Describe the issue/error/question

I have a Notion database with entries.
In N8N I do a getAll Pages from the Notion Node, and it shows all the entries correctly.

That’s why I assume each entry in my database is called “page”.

When I use the Notion Trigger Nodes, however, the wrong event fires.

I add an entry in Notion and expect N8N to trigger the Page Added to Database event, but that doesn’t happen. It triggers the Paged Updated in Database event (also typo in there I think). But when I actually update an entry, the active workflow doesn’t trigger, only through manual execution does it fire the Paged Updated in Database event.

Might be a similar issue as with Seatable Trigger described here

Poll times are 1 minute.

Information on your n8n setup

  • n8n version: 0.159.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: Docker

Hi @leprodude, I tried reproducing this, but the trigger is working fine for me.

I used a database looking like this in Notion:

The trigger picked up the new row as expected through the “Page Added to Database” event:

Any chance you can share a screenshot your Notion database to get an idea of the structure? Maybe I was looking into a case that differs from yours.

Ok then I’ll try creating a fresh workflow and see if that changes anything. I had a workflow with two Notion triggers, one for row updated one for row added. After testing both manually I pulled them into different workflows, but maybe something got messed up.

I was trying to accomplish a sync from Notion to a Seatable instance, but not sure it’s practical to even do that… I’ll let you know once I’ve tried fresh workflows with single trigger

1 Like

Thanks so much for your help with identifying the problem here!

Ok, so I created one active workflow with only a Notion trigger for pageAdded, and one active workflow with only a Notion trigger for pageUpdated.

When I fill in the data, pageAdded triggers with as much data as I have filled in up to that point.
After finishing within a minute, the pageUpdated triggers with the full row data.

Changing existing row data doesn’t trigger the pageUpdated though. I’ve tried adding a tag, adding a stage, changing the description of a row. If the “pageUpdatedInDatabase” correlates to a API endpoint or event, then maybe fixing the typo is all we need. From “pagedUpdatedInDatabase” to “pageUpdatedInDatabase”. But then again, it shouldn’t have triggered after completing the freshly added row as far as I can tell…

Hitting the execute manually triggers it correctly and shows the last edited row with updated data.

Anyhting else I should try or post to help with this?