Oauth2 connection between n8n and Zoho Creator


I want to make a connection between n8n and Zoho Creator (EU zone).
In the screenshot below, you can see the settings in our developer zone from Zoho:

Is it correct that we should set “https://n8n.io” as the homepage URL?

I also tried changing “.com” to “.eu” in the urls, but to no avail.

Then when we click on the “Connect my account” button, we cannot connect. We keep ending up on a page with a 404 error on the top left.

Can anyone help me further? Thanks in advance.

Hi @Martijn3293, welcome to the community!

I am sorry to hear you’re having trouble here. Can you confirm on which domain you are seeing the 404 status? Would that be an n8n tunnel URL (ending with …n8n.cloud)?

If so, I wonder if the tunnel URL might have changed since you added them to Zoho (these URLs aren’t guaranteed to be permanent or have a 100% availability). Could you double-check that?

Your OAuth2 settings look fine to me, I was using very similar settings for another Zoho service recently (these ones).

Hi MutedJam,

The url’s are the same and are ending with n8n.cloud.
I’m running n8n on local desktop. Could this cause the problem?

n8n desktop would use a tunnel URL by default, if there’s a problem with the tunnel URL server this could indeed cause the behaviour you are seeing.

Could you try closing n8n desktop and then remove the entry for the old tunnel URL as described here? Your URL doesn’t look broken, but perhaps it has become unavailable for a different reason.

Restarting n8n worked. I can now connect to Zoho Creator.

However, I am now running into a new problem. I still can’t manage to send data from n8n to an application in Zoho Creator. Do you see where I might have set a wrong setting?

Hi @Martijn3293, I am afraid not as I am not an active Zoho user. The error message you’re seeing is coming from Zoho, so you might want to check their documentation on what exactly is required for your endpoint. Perhaps there is a specific parameter missing from your request body?

Hi @MutedJam
It succeeded in sending data. Thank you.

1 Like

Very nice, thanks so much for confirming!