Pagination on request feature

Describe the problem/error/question

When I try to request more than one page using the “pagination” feature, I always get the first page as a response. I’m not having issues with the expressions (e.g., $response and $pageCount). It’s working fine with a script in Python and in Insomnia.

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Information on your n8n setup

  • n8n version: 1.31.2
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: windows 10 22H2

Hey @Denkard,

Welcome to the community :raised_hands:

Can you try removing the initial page option from the request and see if that helps?

1 Like

Hey @Jon , thank you!

I tried your guidance, but the error persists the same. I re-ran some tests regarding when to stop pagination but apparently that’s not the issue either.

The only other thing I can think of is it will be with the when to stop. If you set it to stop after 2 do you get different results?

1 Like

Hi @Jon, thank you for the support.

None of my attempts worked; I had to handle pagination using other nodes.

I also tried what you suggested, without success.

It seems like the controller isn’t updating the parameter for the next call, so it fetches the first page every time. I just updated to version 1.33.1, and the error persists.

Yeah that looks like the page isn’t updating, I have just tested using the GitHub API using a page option and that appears to be ok (example below), I am not sure why that one isn’t working though.

1 Like

Hey @Jon!

Reinstalling n8n from scratch seems to have resolved the issue, and everything is now working normally, including the same node that was re-imported. I have no idea why it wasn’t working. Thank you for your time and effort.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.