Problem with Openai node (ChatGPT) stuck on "Executing node..)

Hello everyone,

I’m turning to you because I’ve been having a problem for the past two days, and I can’t seem to find an answer on Google or YouTube. I’m new to n8n and I’m creating a workflow for content creation. However, I’m running into a problem: the OpenAI node is stuck on “executing mode” and isn’t returning anything. I don’t know what the problem is. I’ve checked and rechecked the settings, and everything seems fine. Does anyone have any ideas?

The node prompt comes from a Google Sheets file. It’s a fairly long prompt. Could this be the problem? (Which would seem strange to me, because with Make, it works without a hitch).

I ran a test with a short prompt and, indeed, it works. But I can’t find a logical explanation for the difference in use between a long and a short prompt.



Information n8n setup:

  • n8n version: Version 1.27.3
  • Docker

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Haniel_Compaore :wave: Welcome to the community :tada:

While I wouldn’t be able to explain why it works differently on another platform, it looks like you’re making 187 calls to the Open AI node, which is unfortunately going to take some time :sweat_smile:

If possible, you can try to split these calls up so that the node has fewer items to return, but otherwise it will probably be slower with that many requests at once.