Queue mode not working

Describe the problem/error/question

I have an n8n ECS instance running on AWS + redis with auto-scale

What is the error message (if any)?

Yesterday I had some issues with localhost, but I managed to fix them by setting up variables.
I’m still seeing this error when I try to see the executions list:

Sometimes when I go to the workflow list, I get this window that never finishes loading:

Sometimes I see this when I F5:
image

Then made a new workflow, added a webhook JavaScript to resolve Fibonacci problem (to test capacity) and a response webhook with the Fibonacci solution.

It works when I request it from the webhook-test but not when I try to run it from the production webhook: I get these two errors:

{
    "code": 0,
    "message": "There was a problem executing the workflow"
}

or

{
    "code": 404,
    "message": "The requested webhook \"POST 23435f7b-1345-4df7-acf1-109b2cf930b6\" is not registered.",
    "hint": "The workflow must be active for a production URL to run successfully. You can activate the workflow using the toggle in the top-right of the editor. Note that unlike test URL calls, production URL calls aren't shown on the canvas (only in the executions list)"
}

I togged a few times the “Active” toggle to make sure something didn’t go up correctly…

Any ideas??
Thanks!

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.7.1
  • Database (default: SQLite): PostgressDB
  • n8n EXECUTIONS_PROCESS setting (default: own, main): queue
  • Running n8n via (Docker, npm, n8n cloud, desktop app): ecs aws
  • Operating system:

HI @yukyo :wave: This sounds like a configuration problem - can you post your Docker compose file as well as any logs you have? :eyes:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.