Running cat command n8n docker

Hello! Help please, the “cut” command is not executed, that is, the output of information does not come back, the command is executed on the som server and I receive the data, nothing happens through the web. I want to get information from a file but nothing happens

Hey @This_is_real_life,

Are you using the execute node to run the cat command? I have given it a quick go here and the cat command seems to be returning data.

How do you have n8n installed is it in a container?

1 Like

this is my first experience with docker, put on man Server Setup | Docs
I do not have such a directory as you have on the screen

does not display messages at all

That is odd uptime should return something.

My theory with the cat option was that the file you were trying to read was not available to the container but uptime not working is really odd.

What version of n8n are you running and just to double check you did hit the execute node button at the top right?

1 Like

of course I started, 0.142

verified the command, noticed that he did not execute it at all, tried to execute it with saving cat / root / files / 123 >> / root / logs
nothing survived

Is it possible that the node is disabled? or is the node before the SSH node not returning any data? Can you share your workflow? To do so, just copy all the nodes and paste them here.

1 Like

what are you speaking about?


that’s all there is, not even the uptime command is displayed, I understand that the command is not executed on the server, I tried cat / root / files / 123 >> / root / logs
no result

As I suspected, the executed command node is disabled (that is why it’s greyed out). Just click on it and press d on your keyboard or click on the play-like button that shows when you hover over the node - check the image below.

image

1 Like


image

Now it’s executing. I would do something simpler before using cat, like doing a ls -l to see if at least list the files within the root directory;

1 Like

As I understand it, he does not see anything (but how do I know which directory I am in?
the pwd command shows a directory that I cannot find

The command is being executed in the container, not in the host. The container has its file system. Suppose you want the container to have access to the files in the host; you need to use volumes. Assuming that you followed the server setup tutorial if you want to have access to the file 123, you need to add it to /root/n8n/.n8n in the host, and in the execute the command, you should be able to reach it using cat /home/node/.n8n/123

1 Like


does not find
version: “3”

services:
traefik:
image: “traefik”
restart: always
command:
- “–api=true”
- “–api.insecure=true”
- “–providers.docker=true”
- “–providers.docker.exposedbydefault=false”
- “–entrypoints.web.address=:80”
- “–entrypoints.web.http.redirections.entryPoint.to=websecure”
- “–entrypoints.web.http.redirections.entrypoint.scheme=https”
- “–entrypoints.websecure.address=:443”
- “–certificatesresolvers.mytlschallenge.acme.tlschallenge=true”
- “–certificatesresolvers.mytlschallenge.acme.email=${SSL_EMAIL}”
- “–certificatesresolvers.mytlschallenge.acme.storage=/letsencrypt/acme.json”
ports:
- “80:80”
- “443:443”
volumes:
- ${DATA_FOLDER}/letsencrypt:/letsencrypt
- /var/run/docker.sock:/var/run/docker.sock:ro

n8n:
image: n8nio/n8n
restart: always
ports:
- “127.0.0.1:5678:5678”
labels:
- traefik.enable=true
- traefik.http.routers.n8n.rule=Host(${SUBDOMAIN}.${DOMAIN_NAME})
- traefik.http.routers.n8n.tls=true
- traefik.http.routers.n8n.entrypoints=web,websecure
- traefik.http.routers.n8n.tls.certresolver=mytlschallenge
- traefik.http.middlewares.n8n.headers.SSLRedirect=true
- traefik.http.middlewares.n8n.headers.STSSeconds=315360000
- traefik.http.middlewares.n8n.headers.browserXSSFilter=true
- traefik.http.middlewares.n8n.headers.contentTypeNosniff=true
- traefik.http.middlewares.n8n.headers.forceSTSHeader=true
- traefik.http.middlewares.n8n.headers.SSLHost=${DOMAIN_NAME}
- traefik.http.middlewares.n8n.headers.STSIncludeSubdomains=true
- traefik.http.middlewares.n8n.headers.STSPreload=true
environment:
- N8N_BASIC_AUTH_ACTIVE=true
- N8N_BASIC_AUTH_USER
- N8N_BASIC_AUTH_PASSWORD
- N8N_HOST=${SUBDOMAIN}.${DOMAIN_NAME}
- N8N_PORT=5678
- N8N_PROTOCOL=https
- NODE_ENV=production
- WEBHOOK_URL=https://${SUBDOMAIN}.${DOMAIN_NAME}/
- GENERIC_TIMEZONE=${GENERIC_TIMEZONE}
volumes:
- ${DATA_FOLDER}/.n8n:/home/node/.n8n
- /local-files:/files

The screenshot says “No such file or directory” this means. There is no such file present.

Can you run this command?

ls /home/node/.n8n

Also, Can you tell us your usecase or what you’re trying to achieve? So we can help you with that more clearly

2 Likes

I’m trying to set up a telegram bot, at work without using docker it turned out to be done, now I want to do for myself a little differently

using the command, I managed to create a folder inside the directory, but I can’t find it on the server