Setting up from scratch n8n with Portainer and Nginx Proxy Manager


There are already several threads on this topic, for example:

Unfortunately, they do not cover the process in detail.

Who has already set it up and has it working,
please post screenshots so people can set it up from scratch.

How you set up the Portainer so that the n8n works fully ?

ps I don’t really understand which settings and what they are called, so screenshots will be very useful

Thank you so much in advance!

I just installed n8n using these instructions:

n8n works!

Thank you so much Jon!


Hey @Mikhail,

It is nice to see that it helped someone :slightly_smiling_face:

Hey @Jon !

Thank you so much again for the manual!

I don’t know what it has to do with, but I have the error “ERR_SSL_PROTOCOL_ERROR”
when I pressed this button:

there was the error at the end of the process:

My environment:


Could you please tell me what this error is caused by?

The browser doesn’t think the ssl version is correct which is odd.

Try removing the port from the webhook_url as it isn’t needed (unless you really want it) and in nginx proxy manager enable the force ssl option and see if that helps

1 Like

It worked! :+1: :muscle:
Thank you!


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.