Shopify triggers on n8n.cloud Trigger Not working

No data after a long wait
Screen Recording 2022-04-18 at 12.40.11 AM

Workflow Executions 0/0 Also empty

Shopify works fine, but Shopify triggers don’t work

Are you doing the event (deleting a product) in Shopify? Else, the trigger it’s not going to receive anything. Also, keep in mind that in test mode, the trigger only is active for short time. If you want to keep the trigger listening all the time you need to active the workflow.

1 Like

I deleted the product, but the trigger did not receive any data.
Please see the video
Shared with CloudApp

You are not gonna be able to see it there but instead in the executing tab. Did you check the executions tab? Something the services (in this case Shopify), takes a minute to trigger the event. Also, in the trigger, when you open the Webhook URL label, does it say localhost?

Webhook URLs : https://XXX.app.n8n.cloud/webhook/aea6f285-9c39-4b25-8f03-75a1c0090b17/webhook

I set up a shopify trigger to send emails. It’s been several hours and I haven’t received any emails
Tried deleting products and adding products, but no trigger

Hey @VictorXd,

Did you check the execution log? It could be running but failing to send the email.

Hey @jon
Workflow Executions is mpty, Send the email is valid. I tested it and it works

Hey @VictorXd,

I wonder if it is related to shopify no longer working with private apps and needing custom apps to work.

Thought exactly the same. Someone reported that in another post. I guess it’s a matter of testing.

I thought I’d add to this, as I’ve currently got Shopify triggers working with Custom Apps, but I don’t exactly remember how.

It seems during the Private App deprecation/transition, the interface to view webhooks created by a Custom App has gone away. I pretty convinced I was able to see these previously, with an interface similar to this screenshot, albeit from the App configuration:


(from Understanding Shopify Webhooks: A Comprehensive Guide 101)

The current documentation references creating webhooks manually via Settings > Notifications > Webhooks but these do not show in the responses to the Shopify Admin API (authenticated by custom app access token), nor do the webhooks created in the Admin API (authenticated by custom app access token) show here. I suspect because it’s showing/creating the webhooks based on my user account, not the Custom App.

It could be I ran into the issue described here and went ahead and created the webhooks manually in the UI. At the moment, these are working fine; I’m receiving webhooks on creation of a new product.

I can see, update and create new webhooks using the Admin API manually, ie: in Postman, via REST or GraphQL. The Shopify node code uses these same calls, though an older version of the API, but testing again in Postman with the older API still shows these webhooks OK.

I suspect the calls in the Shopify node to create the web hooks is failing and will need debugging. It may have been this way for a while. I’ll try to look into this, but I don’t have a lot of spare time.

Edit

I’ve had a play and I’ve been able to confirm activating the workflow creates the webhook via the Admin API. I did come across Shopify rejecting HTTP protocol URLs and also ‘localhost’ domains. I resolved both of these by setting the N8N_HOST and N8N_PROTOCOL environment variables.

I can’t imagine either of these affect you if you’re running in the n8n cloud, so it’d be good if you can check your Shopify Admin API for the webhooks to see whether they are created succesfully and whether the URL for the webhook on the n8n side is what you expect.

You’ll need your X-Shopify-Access-Token which in n8n is the Credential Password and starts with shpat_*