The latest version would be: n8nio/n8n:0.101.0-debian

1 Like

Thanks for the tip on that one earlier Jan.

In Docker Hub I see that there are two tags for latest, including latest-rpi.

Would it be possible to add a latest-debian tag to the registry that we can reference in docker-compose.yml files?

Sure. Beginning with the next release will it now automatically also tag the latest debian image with n8nio/n8n:latest-debian.

Just also manually tagged the latest version (currently 0.107.0) of the debian image the same way. So you can already start using it now.

1 Like

Speedy! Thanks a lot.

Another issue about this Unable to send e-mail from n8n · Issue #1491 · n8n-io/n8n · GitHub

Hello everyone, I had this and other errors like smtpCreddentials does not exist… Using the version for ubuntu(20), after activating GMAIL API you configure the permissions, it was only install the lib sudo apt-get install libsasl2-modules, it is it is working correctly.

Hey @Fabricio_Kerber,

Welcome to the community :sparkling_heart:

Thank you for sharing the solution. Did you try the SSL options that the node has? Did it give you the same errors?

Just solved a similar error by disabling SSL switch in the SMTP credentials!
Just in case sb else finds this and hasn’t tried that yet…

I confirm this solution. Add to your docker env settings:
I assume STARTLS kicks in with that off.
In any case email sending works now.


Hey @Erixun,

Welcome to the community :raised_hands:

It does indeed so you are telling it not to use SSL so it instead uses starttls, it seems a bit off but that is how the package under it handles things.

you mean install it where? on n8n sever?

sorry so everything fails if starttls is enabled?

For me this was the fix: Cannot get mails via IMAP - #5 by MutedJam
I did not know beside disabling SSL/TLS in config window I had to do this!

This worked for me, thanks :orange_heart:

Hey guys, just installed n8n using docker and tried to setup smtp node. Using I run into the very same err.
I startet off with the default docker image and also tried latest-debian (since my docker-host is running debian 10.12) … but no dice either way.
The topics here and in the linked thread on github are not that new really, so I wonder if I am actually running across the same issue or whether its just similar that fails on same code-location?

Hey @coeotax,

Welcome to the community :cake:

If you are seeing the same error you need to set the SSL option to false so that it uses StartTLS.

Hi Jon,
thanks so much for the hint - that works indeed!

1 Like

where I can get the docker image ending with -ubuntu

Hi @Muhammad_Hafil, welcome to the community!

The -ubuntu images no longer exist since ~2 years. You want to use the -debian one these days as suggested above. That said, even the standard image should work with pretty much all email providers these days.

If you can share your email provider and the settings (except your username/password of course) you are currently using we might be able to help you with the configuration. Seeing this thread is 2.5 years old It’d be great if you can open a new thread when doing so and provide all details from the question template.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.