SSH execute returns error

Hi everyone!

I’m trying to execute some commands via SSH but getting an error (attached screenshot).
I use correct credentials, but can’t understand what’s wrong here?

Does anyone had the same issue?

Regards,
Ilya

  • n8n version: 1.2.0 (1.2.0)
  • Database you’re using (default: SQLite): default
  • Running n8n via desktop

Welcome to the community @am-monkey!

It looks like the screenshot is missing. Can you please either post the error message or upload the screenshot on another page and add the URL to it here. Thanks!

Hey @jan!

Sorry. Seems I forgot to upload image. I attached it now.

Thanks!

Hey @am-monkey,

That looks like n8n can’t find / connect to the host, does an SSH client from your desktop connect ok?

Do you also happen to know what version of SSH is running on the server?

Hey @jon!

Thank you for your reply.

This host is accessible via SSH. I work there via MacOS terminal and Termius app.

1 Like

Hey @am-monkey l,

That is unusual, what SSH server is it? That error tends to be fairly well defined as it can’t talk to the server properly but there could be other reasons behind it.

Knowing the server version may help, I take it there is no special configuration like MFA?

I assume desktop is running on the same machine you normally connect from as well? I know there is some odd issue at the moment with connecting to ionos servers from the desktop app.

It’s VPS which I use for my projects.
It is running on Ubuntu 20.04.4 LTS (GNU/Linux 5.4.0-107-generic x86_64)

That is perfect it gives me something I can test against, is there any special changes in the ssh config or is it just standard?

@jon seems that this is a server issue. I’ll try to reinstall and check it.
Also I tried to connect to another server and everything is ok.

Hey @am-monkey,

That is the same issue I ran into when testing with IONOS, It worked with other servers I have access to and different VMs but for some reason something their config is doing just causes problems.

I still need to set aside some time to check on 20.04 but I think I had a 20.04 droplet running that was working which was odd.