Subworkflow response when have a "wait" node

I have a node “Execute workflow”. In this sub-workflow I have a WAIT node (Usually DAYS) - always as the last node

Its working! The parent workflow do all his stufs and start the next workflow. But on “executions” im getting an error on the parent

TypeError: Cannot read properties of undefined (reading 'stack')
    at Object.executeWorkflow (/usr/local/lib/node_modules/n8n/dist/src/WorkflowExecuteAdditionalData.js:552:66)
    at async Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/ExecuteWorkflow/ExecuteWorkflow.node.js:162:34)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:451:47

I’m sure the error is caused by this subworkflow “answer” (with waiting days)
How do I configure this subworkflow answer for the parent? To respond like a webhook or something like these

Parent worfflow finish like these:
image

And then, subworkflow starts (and wait for 7 days):
image

(My first topic, starting in the community)

Hey @Sergio_Brito, welcome to the community and sorry for the trouble!

Tbh, I never tried a longer wait in a sub-workflow. I’ll set up a test on my side to see if I can reproduce the problem.

As a possible workaround, have you considered triggering your sub workflow via an HTTP Request in your parent that simply hits a Webhook URL in the sub? This would use a different logic than the Execute Workflow node and might not have the same problem (as long as your webhook node responds immediately).

Hey @MutedJam, thanks for your answer, so let’s go!

I tried it before I even posted this question (webhooks), and it works too!
The only problem using webhooks instead of “execute workflows” it’s because I have to set up all this workflows as ‘active’ to get trigered. I’m almost at my limit

image