SuiteCRM Integration

Hi, is it possible to install SuiteCRM Node in a N8N docker container?

Thanks

1 Like

if you use the standard image (Alpine)

Steps

docker exec -it n8n /bin/ash

I like to use bash (optional)

apk add bash bash-completion bash-doc
bash

change to n8n modules directory

cd /usr/local/lib/node_modules/n8n
edit:
better use the recommended folder
mkdir /home/node/.n8n/custom
cd /home/node/.n8n/custom

install module n8n-nodes-dnc-suitecrm

n8n-nodes-dnc-suitecrm need mmmagic so you need to install dependencies first, then install the module, then delete the dependencies again.
apk --no-cache --virtual build-dependencies add \ python \ make \ g++ \ && npm i n8n-nodes-dnc-suitecrm --unsafe-perm \ && apk del build-dependencies

install n8n-nodes-dnc-suitecrm

npm i n8n-nodes-dnc-suitecrm

go back and restart

type exit to logout or type ctrl+d
docker restart n8n

enjoy your new module(s)

!!! Attention - changes are temporary !!!

These changes are only valid until you delete and recreate your container. To make them permanent, you should use a custom Dockerfile in order to create a custom image.

1 Like

this seems very useful.
@svenjanssen I tried to walk through your install tutorial above.
When I type

apk --no-cache --virtual build-dependencies add \ python \
make \ g++ \ && npm i n8n-nodes-dnc-suitecrm
–unsafe-perm \ && apk del build-dependencies

it gives me an Error:

ERROR: ’ python’ is not a valid child dependency, format is name([<>~=]version)

any ideas how to solve this?

1 Like

Same problem here.

@Jason_Den @alexhammerschmied make sure you upvote the feature request. The more votes, the more chances of being developed. That way, this node will come out of the box with n8n.

2 Likes

Why don’t you make a PR to the project with the SuiteCRM implementation you created?

sorry I have not encountered this. I could only google search too

I don’t quite understand, PR with which content?

The suiteCRM node?

done :slight_smile: I am happy to test something regarding a PR.

@svenjanssen when I connect the node to my suitescrm and try to run a “get all” function it gives mi a
500 Error - undefined.
Any ideas why this would happen?

Hi people,
as mentioned in this post: External CLI tools in n8n - #13 by alexhammerschmied
i was able to create a Dockerimage which installs the plugin and the dependencies. So from n8n side everything seems to work.

But I can’t get the connection to work. What am I missing? I walked through all the steps with the crm module but somehow no data gets fetched or sent to suitecrm.

Can anybody help me? Does someone know where to look or dig deeper?

How were you able to resolve the previous errors with the “python is not a valid…” and the 500?

Things to look for:
Did you install the suitecrm API according to the docs? Does it work with postman? (Many errors were present on suite side in the past, some of them needed manual fixing. I think they are resolved depending on which version you are running)

Did you install the plugin for suitecrm that comes with the webhook?

Please create a regular webhook node (not suite), click open “URL” and check if it is correct “https://your-domain.com:1234

Hi @svenjanssen!
I am able to get the swagger.json with postman.
It seems to be reachable. But as soon as I try to connect to SuiteCRM with OAuth2 it gives me an error and tells me it can’t complete the token request.

I don’t know what to do.

Swagger.json can usually be reached without authenticating. To make sure everything works please authenticate using postman. There is a suitecrm postman package to be found somewhere so you don’t have to create it yourself. Then you can test oauth2 and the endpoints.

Also check (.htaccess issue on suitecrm side)

2 Likes

we did it recently

1 Like

Hello lovely people!
Any news on this? Can i help testing?

Hi Alex,

unfortunately I can’t edit the post up there so here is how I would do it today:
Install n8n using our image (digitalboss/n8n-custom-nodes:latest) with env [email protected]l-boss/n8n-nodes-suitecrm;
Using the image you can also load other modules such as the trigger automatically. If you mount the volume you can then use n8nio/n8n image afterwards and it will load the modules which were installed. The modules only load when the container is first created, so for any updates of the custom modules you need to recreate the container.

The @digital-boss/n8n-nodes-suitecrm is the new package, it does not require mmmagic procedure from above anymore.

If you go do it the old way, you want to npm i @digital-boss/n8n-nodes-suitecrm into /home/node/.n8n/custom folder