Telegram trigger doesn't work

I faced a problem that couldn’t solve so far using google :slightly_smiling_face:
To describe the problem I’ll use the following workflow

I’ve created a bot, added to a group, saved credentials in n8n, setup everything in the workflow(chose credentials, set chat id, etc), saved workflow, executed, activated.

I write message to the bot in Telegram and nothing happens but if I sent a post request to the test/production webhook URLs everything works fine and receive a message “Workflow got started.”. Then I receive a message from the bot " Hi !Your message did not contain any sticker.". So I assume that everything works fine.

Can’t figure out why my messages to the bot do not trigger workflow.

I don’t use n8n tunnel. n8n is behind nginx. Webhooks in general work good.

Welcome to the community @mkz!

Sorry to hear that you have problems. Let’s see if we can figure that out.

I am a little bit confused about this part: ... saved workflow, executed, activated.
When you execute that workflow (if you press “Execute Workflow”) it should actually keep on waiting till it receives a message from Telegram. Does it not do that for you?

Yes, it’s waiting for a message.

Ok and if you then send a message it never resolves the Trigger node?

Btw. not sure if it is helpful but here is also a tutorial with Telegram:

Thanks. I saw this article :slight_smile:
It never resolves the Trigger node.
Could you please give me some hints how telegram trigger works. Should I see some incoming requests in nginx access log file? Now I see there only webhooks that I trigger manually or n8n rest calls when I edit, create, execute workflows.

Ah yes if you have nginx in front of it, you should also see the incoming request in its logs.

For me it sounds like the Webhook URL is maybe not correct. If you click on “Webhook URLs” on the Telegram-Trigger Node:

  • Is it an HTTPS URL
  • Is the SSL Certificate valid
  • Is the URL for “localhost” or your domain like “

Thanks. It was not enough info how to debug such a case. You were right - SSL certificate/nginx settings issue.

It was a problem with my certificate and nginx settings. Chrome showed that everything is ok with the certificate but then I checked here
In general everything was ok but “This server’s certificate chain is incomplete”

Also I found that we can get some info about a bot webhook from Telegram API.
Open in browser<=BotApiToken=>/getWebhookInfo
In my case there was the following info

    "ok": true,
    "result": {
        "allowed_updates": [
        "has_custom_certificate": false,
        "last_error_date": 1590781924,
        "last_error_message": "SSL error {error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed}",
        "max_connections": 40,
        "pending_update_count": 29,
        "url": "https://domain/webhook-test/4/telegram%20trigger/webhook"

Solution: Use a full chain certificate in your nginx settings.

Really glad that you got it working! Have fun!