Thehive webhook local url

Describe the question

Hello, I am trying to configure n8n thehive webhook. Both Thehive and n8n is on the same machine. Bu can’t get it done. One issue that confuses me is that , webhook url is in the cloud. N8n is self-hosted should’t url be a local one?

What is the error message ?

Information on your n8n setup

  • n8n version:0.204.0
  • Database you’re using (default: SQLite):Postgre
  • Running n8n via Docker

Hi @stephenmccarter, welcome to the community!

It seems you are using the tunnel service offered by n8n (docs) in order to get a public webhook URL. You can still reach your n8n instance on localhost when doing so (http://localhost:5678/webhook... unless you have changed the n8n default port), but the UI would show the tunnel URL and trigger nodes would also register tunnel URLs with other services.

In order to use the local URL by default instead you would need to start n8n without the tunnel option.

Hope this helps!

Thanks for reply, it solved my problem. About the tunnel option, when I started the service, I used default commands , I guess I didn’t know what some options meant.

1 Like

Sweet, glad to hear this works! You might also want to check out the WEBHOOK_URL environment variable using which you can override http://localhost:5678 if needed (for example if you use n8n behind a reverse proxy).

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.