Twitter Node: Error 403

Describe the problem/error/question

I would like to publish a tweet via n8n, I created an app on twitter developer portal and gave access to v2 API endpoint. Following the twitter API documentation, it is supposed to work with the free plan.
But instead on n8n it returns an error message.

What is the error message (if any)?

ERROR: Forbidden - perhaps check your credentials?
You currently have access to a subset of Twitter API v2 endpoints and limited v1.1 endpoints (e.g. media post, oauth) only. If you need access to this endpoint, you may need a different access level. You can learn more here: (the link redirects to my twitter API dashboard)

Please share your workflow

Share the output returned by the last node

NodeApiError: Forbidden - perhaps check your credentials?
    at Object.twitterApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Twitter/GenericFunctions.js:26:15)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Twitter/Twitter.node.js:153:40)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:646:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:631:53

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
    n8n cloud
  • Operating system:
    ubuntu 22.04

Hi @kitsuiwebster :wave: Sorry to hear you’re running into this!

Can you try heading over to and updating to 1.1.0 or above? That should fix this up, as there was a complete overhaul to the Twitter node in that version :slight_smile: The latest beta is 1.1.1, so that would work!


Hello @EmeraldHerald

I updated to 1.1.1, but I still get the same issue :confused:

Just to double check here, @kitsuiwebster - did you delete the old Twitter node and add a new one from scratch, while creating new credentials? Otherwise you’d unfortunately see the same error.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.