Twitter OAuth 2 credential disapper in version 1.0.5

Describe the problem/error/question

I upgrade to version 1.0.5 today.
I found my Twitter OAuth2 credential was not available.
I thought there may be a change in twitter node, so I delete it and try to recreate it.
But there is only ‘Twitter OAuth API’,but no ‘Twitter OAuth2 API’.

What is the error message (if any)?

2023-07-25-122421_462x310_scrot

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.0.5
  • Database (default: SQLite): PostgresSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): using default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: NixOS 23.05

Why Twitter V2 API related code was deleted in 1.0.x version? Can’t found any info in Release notes | n8n Docs .

Hey @browse,

v1 was created from an earlier version of n8n with some fixes picked up along the way but not some of the new node features. Tomorrow we are planning to release 1.1.0 which will bring v1 back in line with the features released between 0.234 and 0.236.

1 Like

@Jon
Got it. Thanks for your reply. :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.