Twitter oauth immediately errors?

Describe the issue/error/question

When I click the “connect my account” button in the twitter widget inside of n8n.cloud I immediately get an error

What is the error message (if any)?

Please share the workflow

  1. Add twitter widget
  2. Click connect account
  3. Get error

Information on your n8n setup

  • n8n version: latest on n8n.cloud - instance launched today

Hi @garm, I’m really sorry for this

Twitter has restricted the shared n8n.cloud application used here because it has been abused by a user. We’ll most likely change towards letting users create their own Twitter applications (similar to self-hosted n8n instances) in the next week to fix this. You might want to follow the main thread about this for more updates:

Oof - that is very unfortunate. Especially as I had a still functioning Twitter integration working whose workflow accidentally got deleted two days ago. There’s no way to reinstate that instance with its oauth integration somehow, right?

You can reach out via the cloud help center for us to check whether we can recover an earlier database backup, but I don’t think this would restore Twitter functionality unfortunately.

Before Christmas, I could still authenticate with Twitter and search Tweets on n8n.cloud, but this no longer seems to be the case. I haven’t upgraded my n8n.cloud version since or changed anything else, so I reckon Twitter might have tightened the screws even further here.

I’d therefore suggest creating your own application in the Twitter developer portal and using the HTTP Request node for the time being in order to interact with the Twitter API. I’ve quickly tested this on n8n.cloud and it appears to work fine:

The below example would for example fetch the recent Tweets from n8n_io using this endpoint:

Example Workflow
{
  "nodes": [
    {
      "parameters": {},
      "name": "Start",
      "type": "n8n-nodes-base.start",
      "typeVersion": 1,
      "position": [
        240,
        300
      ]
    },
    {
      "parameters": {
        "authentication": "oAuth1",
        "url": "https://api.twitter.com/2/tweets/search/recent",
        "options": {},
        "queryParametersUi": {
          "parameter": [
            {
              "name": "query",
              "value": "from:n8n_io"
            }
          ]
        }
      },
      "name": "HTTP Request",
      "type": "n8n-nodes-base.httpRequest",
      "typeVersion": 1,
      "position": [
        460,
        300
      ],
      "credentials": {
        "oAuth1Api": {
          "id": "54",
          "name": "[Twitter] MutedJam"
        }
      }
    },
    {
      "parameters": {
        "fieldToSplitOut": "data",
        "options": {}
      },
      "name": "Item Lists",
      "type": "n8n-nodes-base.itemLists",
      "typeVersion": 1,
      "position": [
        660,
        300
      ]
    }
  ],
  "connections": {
    "Start": {
      "main": [
        [
          {
            "node": "HTTP Request",
            "type": "main",
            "index": 0
          }
        ]
      ]
    },
    "HTTP Request": {
      "main": [
        [
          {
            "node": "Item Lists",
            "type": "main",
            "index": 0
          }
        ]
      ]
    }
  }
}