Unable to connect with Gmail OAuth

I am simply trying to connect with Gmail via OAuth
All things happen smoothly
except after signing in

getting this

This site can’t provide a secure connection

n8n-moin.duckdns.org sent an invalid response.

ERR_SSL_PROTOCOL_ERROR

havent made any workflow yet

i can successfully able to connect with service but unable to execute node successfully

Information on your n8n setup

  • n8n version: 1.0.5
    Docker Compose Selfhosted
    Ubuntu

i have setup ssl already

https://n8n-moin.duckdns.org/

anybody please help I am trying from morning

I am having same problem
Are you running docker?

Hi @Anju_Aayesha, welcome to the community!

It appears n8n-moin.duckdns.org is using a different hostname in its SSL certificate (check for example SSL Server Test: n8n-moin.duckdns.org (Powered by Qualys SSL Labs)) which is why you would be seeing this error.

I suspect that once you issue a valid SSL certificate for your n8n instance the error will disappear.

If you’re having trouble with this, can you confirm how exactly you have deployed n8n? Are you using a reverse proxy server? How did you obtain the certificate?

You could also try setting the NODE_TLS_REJECT_UNAUTHORIZED=0 environment variable instead, but this will disable certificate validation and is therefore a security risk (see the Node.js documentation on this option).

2 Likes

Thanks for reply,
Now I am able to get it working
I bought a new domain
followed exact instruction on documentations & voila it worked

1 Like

Amazing, thx a million for confirming!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.