Unable to Execute Flow. Local Server! "cert is not initialized"

We’ve installed n8n on our on-prem ubuntu servers using npm global install. We are unable to execute the flow. FYI - we haven’t inserted the activation key yet. Please suggest ways to solve this. Also, if activation key is needed, please suggest ways to get the key.

This is the console log we got “renewal is failed because current cert is not initialized”. Please help us solve this issue

image (10)

Hi @Krish_Jain - sorry to hear you’re running into this!

Looking closer at the error - you may also be running n8n behind a reverse proxy that has not been properly configured.

Are you using a reverse proxy? The websockets option might help you out here - N8N_PUSH_BACKEND to websocket. :+1:

We are using nginx for reverse reverse proxy. I am attaching the configuration file for n8n subdomain (we are redirecting www to non www n8n subdomain as well). I’ve also set export N8N_PUSH_BACKEND=websocket, but it is showing the same error. Attaching the config for nginx

Can you take a peek at this thread, @Krish_Jain , and see if these various fixes and links help you out with your configuration?

Can you try connecting directly to n8n bypassing the reverse proxy that will confirm if the issue is with the proxy configuration. Looking at your config I would also try adding the 2 options below which will probably get it working.

 proxy_buffering off;
 proxy_cache off;
1 Like

We’ve defined the environment variable export N8N_METRICS=true but the /metrics endpoint is not working. Attaching the screenshot for reference. Do I need to do anything else?

Hey @Krish_Jain,

One enabled n8n just needs a restart and you should be good to go, If it isn’t working it could be that the environment option is not correctly configured.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.