[urgent] personal access keys Airtable not working, depreciate 1 february 2024

We are trying to authenticate with Airtable using their Personal Access Token. We get back an unauthorized from Airtable, while the deprecated API key works. The same problems as described in Airtable authentication with Person Access Token - #3 by jb8n

We are using version 0.221.2

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

welcome to the n8n community!

I double-checked and the connection with the Personal Access Token is working on my side.

This is how I configured on the Airtable developer portal:

and this is how I added it into the n8n credentials:

Double check the scopes assigned to the token an the Base access and let me know if it works.

ps. Please also provide the following information so the community can better assist you:

Thank you for your fast reply! Unfortunately we still get the following error message:

Error: Authorization failed - please check your credentials

HTTP Code 401.

N8N version: 0.221.2
Running n8n: Cloud

Furthermore, we checked the documention. When creating Airtable credentials, we only get the option to input an API key, so no access token.

Could the solution be to upgrade our N8N version? We would love to avoid that, if not necessary. And if we would update the version, and things stopped working, could we roll back to the current used version?


Hey @JOSD,

I would recommend upgrading, You won’t be able to roll back the version once you have upgraded but we can restore from a backup. I would however recommend doing this on Monday if you want to do it as our team is not available 24/7 and I wouldn’t want you to be without your instance over the weekend.

@Jon Hey, developer of the team of JOSD here. We upgraded to the latest stable version of n8n (1.25.1). Unfortunately, we still get a 401 back from airtable.
Weird thing is: the documentation states that in the n8n Airtable credentials dialog, “Access token” should be selected. The only option we have in the credentials dialog is “API key”, which is probably the deprecated key of Airtable. No option to select Access token there. Also see screenshot of the dialog attached. Am I missing something?

Ah, I clicked a bit through the n8n credentials and noticed that Airtable with PAT is a different credentials type, not something you have to select within the dialog. It all works now! Topic can be closed :slight_smile:

1 Like

Hey @harmjanr,

Perfect, I have marked your reply as the solution :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.