Wait module stuck on execution

On running my workflow wait module stuck in process(interval 5 minutes).

What is the error message (if any)?

“This execution hasn’t finished yet”


Please share your workflow

Information on your n8n setup

  • n8n version: Version 1.0.5
  • Database (default: SQLite): PostgreSQL
  • Running n8n via (Docker)

Hi @David_Semenenko :wave: I tried your workflow (with the last post request taken out), and it was successful when trying this manually:

It was also successful with the schedule trigger activating the workflow:

Can you share your Docker file and some logs to try to dig into this further?

Hi @EmeraldHerald

Sure pls find github repository link GitHub - DSemenenko/n8n-community

Also I have some cors issue. When I am trying to make POST request from my React App Client to n8n Webhook. I am getting the error.

“Access to XMLHttpRequest at ‘https://api.example.com/webhook/0561e-7f8d-4571-9e7d-e462bffd511c’ from origin ‘http://localhost:3000’ has been blocked by CORS policy: Request header field content-type is not allowed by Access-Control-Allow-Headers in preflight response.”

Before my client was sending request to integromat webhook and everything was fine.
Coule you pls advice how can I solve this issue?

1 Like

Can you try to add CORS options Traefik? That should hopefully fix this up :slight_smile:

Ok, thanks. Is there any news on what I’m doing wrong with WAIT module?

I can see on the top last execution not finished in time in “wait” mode. I made some test and for 5-60 seconds module working as it is. But when I changed it to 2minutes +/120seconds+ it stop working at all. I think there is bug in that module.

@EmeraldHerald
I notice that WAIT module doesn’t work at all as expected

From all of these execution success only once

Still waiting
image
Succeesed

Hi @David_Semenenko :wave: I was unfortunately out yesterday :bowing_man:

Can you try upgrading to the latest version of n8n and seeing if that helps fix this up?

Also, can you try setting your timezone directly in your Docker compose file? Judging by your images, you might be located in Dubai - if so, you can set that through Asia/Dubai, and you can see how to set that here: Environment variables reference | n8n Docs You might be running into timezone issues if the Wait node isn’t behaving as expected.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.