Wait Node not executing After Time Interval

Describe the problem/error/question

I have Wait Nodes that are not executing after they hit their amount of minutes.

What is the error message (if any)?

No error message, the Node just sits in Waiting status.

Information on your n8n setup

n8n cloud

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Can you share the node or entire workflow?

paste workflow code here

Do you have sample data from the webhook?

I expect it’s the ={{ parseInt($(‘Webhook’).item.json["query"]["moreData"]["time"]) }} expression in the Wait Amount field causing an issue

Can you try to embed the workflow? That will make it easier for me to try without needing to recreate the workflow. Just select all of the workflow nodes and copy. Then paste it in a codebock and it embeds. Make a codebock with this icon:

1 Like

Could you share the sample data too?
I see you had it pinned but n8n clears it for security when sharing.

    "headers": {
      "host": "creativeplanning.app.n8n.cloud",
      "x-request-id": "c5958f49da6673036a550e3fecbe2d21",
      "x-real-ip": "",
      "x-forwarded-for": "",
      "x-forwarded-host": "creativeplanning.app.n8n.cloud",
      "x-forwarded-port": "443",
      "x-forwarded-proto": "https",
      "x-forwarded-scheme": "https",
      "x-scheme": "https",
      "content-length": "0",
      "accept": "application/json,text/html,application/xhtml+xml,application/xml,text/*;q=0.9, image/*;q=0.8, */*;q=0.7",
      "user-agent": "axios/1.6.5",
      "sentry-trace": "b373969b057a46d199d7fd82b227f16f-8180b9e767e9aaa4",
      "baggage": "sentry-environment=production,sentry-release=1.26.0,sentry-public_key=762b4594437700783cda760fcf660ddf,sentry-trace_id=b373969b057a46d199d7fd82b227f16f"
    "params": {},
    "query": {
      "msgTs": "1707148866.403279",
      "moreData": {
        "slackId": "U028YCQCC",
        "time": "60",
        "msg_ts": "",
        "channelId": ""
      "time": [
          "json": {
            "formattedTime": "1 hour"
          "pairedItem": {
            "item": "0"
      "jcid": "1234"
    "body": {}

I couldn’t recreate it. I am on an older version (1.24.1)

Does it happen when you test? seems like it may be a bug if you aren’t getting errors

If I test the node it works without issue.

The only thing I can think is that there is a bug, your incoming data is inconsistent, or the parseInt() is causing an issue for some reason.

Bug seems most likely since you don’t have any errors. I checked and the node hasnt been updated between our versions (though i didnt check stuff it depends on).

Try deleting the node and starting with a fresh one and try it in a new workflow and see if that fixed.

I don’t know who to ping on the team, I see people mentioning @Jon for this stuff

I had noticed they eventually stopped so I let one run this afternoon instead of stopping the execution. It completed after 420~ minutes instead of 60 for some reason.

I’m experiencing this as well. Older workflows that have “Wait” nodes seem to still be working as they used to, but today I built a new workflow and the “Wait” node is supposed to wait 5 minutes, it’s been 10 minutes and they are all still in “Waiting” status and I can see in my database that the actions that are supposed to take place after waiting aren’t happening.

Here is an example of the workflow:

And an example of the JSON in the “Webhook” node:

        "headers": {
            "host": "n8n.mydomain.com",
            "user-agent": "axios/1.6.5",
            "content-length": "122",
            "accept": "application/json,text/html,application/xhtml+xml,application/xml,text/*;q=0.9, image/*;q=0.8, */*;q=0.7",
            "accept-encoding": "gzip, compress, deflate, br",
            "content-type": "application/json",
            "x-forwarded-for": "192.425.134.1",
            "x-forwarded-host": "n8n.mydomain.com",
            "x-forwarded-port": "443",
            "x-forwarded-proto": "https",
            "x-forwarded-server": "6346436a8dcbf217",
            "x-real-ip": ""
        "params": {},
        "query": {},
        "body": {
            "field1": "info_here",
            "name": "jim",
            "id": "12334455",
            "type": "45"

Information on your n8n setup

  • n8n version: 1.26.0
  • Database (default: SQLite): Postgresql
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker on remote server
  • Operating system: Ubuntu 20.04 LTS

I have a 60 and a 120 version. I let the 120 run over night and it ran for 480. Based off that it’s going to run for 360, 6 hours, and then add my time to that.

What timezone do you have your n8n instance set to?

UTC-6, Chicago. So that matches up with the 360 minutes. Timezone shouldn’t matter to a timer though right?

It shouldn’t but we are tracking an issue where it does seem to be causing issues.


Awesome. Appreciate it @Jon !

In docker-compose.yml, I have:


And then in the .env file, it has:


And the timezone in the workflow is:

Default - (GMT-08:00) Pacific Time

I’m facing this issue as well. My wait node set for 4 minutes now runs after 5 hours, 4 mins. I’m on the latest n8n version

Try adjusting the time zone in the admin portal to just UTC.