Wait Node At Specified Time Not Executing at Time Specified

Describe the issue/error/question

Wait Node using “At Specified Time” is executing prior to time entered in node.

The n8n documentation appears to show that the time should be formatted as shown below. Is that correct?

I have several Wait nodes with today’s date but different times and all are executing early. It appears that the node is executing based on the date, but not taking the time into consideration.

Also does the Wait node use the local server time or GMT?

I tried both and that did not help rectify the issue.

What is the error message (if any)?


Please share the workflow


Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.214.1
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: ?
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hi @MortgageRockstar

I guess the timezone is not setup correctly for your server.
In the workflow settings, you can see what the default is that is set on your server. (right top of the screen there is the settings under the hamburger)

You can also set it to something else for the workflow here to see if that solves the issue.

Thanks for trying to help, @BramKn . I tried to rule that out by using GMT instead of my local time zone and that didn’t work either.

I just double-checked the time zone in the workflow settings and it is showing my local time zone.

Ok, so the timestamp you are putting in seems wrong.
It should probably be in ISO format

Thanks again, @BramKn

I entered the dates in ISO format and the Wait node now works as expected.

It would be helpful for n8n users if the Wait node documentation for the “at specified time” option was updated by the n8n Team to show this.

hi @MortgageRockstar

Yes it should have stated it but to be honest. I simply missed it before, the use of ISO format is pretty standard.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.