Wait Node set to 24 hours / 1 day - Execution disappears after wait time period

Describe the problem/error/question

I have a few workflows that get called by a webhook and then wait for “X” amount of time to do things. They are all working fine, except my 24 hour wait workflow.

Initially, I set it up to wait “24 hours” but the executions just disappeared and never completed, so I switched it to “1 day” because I remember some conversation a while back about hours vs days when using wait for longer time persions.

Anyway, same result - the execution just disappears once it’s supposed to finish waiting and execute. It doesn’t complete the task it’s supposed to do after waiting (query an API and update a database).

The workflow is set to save successful production executions, manual executions, and to save execution progress.

I DO have “Timeout Workflow” toggled “on” and it’s set to “2 minutes” (my default). Is this the cause? My assumption was that the timeout only applied to the workflow actively doing things, not waiting. I tried to change it to 25 hours to test if that is the issue, but it returned the error, “The timeout is longer than allowed: Maximum Timeout is: 1 hours, 0 minutes, 0 seconds”

What is the error message (if any)?

None, the execution just disappears.

While the executions are “waiting” I can see them in “Executions” but once the 24 hours time is up, they are not there anymore. Filtering by Any Status, Failed, Canceled, Running, Success or Waiting" does not show any past executions.

Please share your workflow

Share the output returned by the last node

None.

Information on your n8n setup

  • 0.236.3 - I am afraid to update to 1.x because I saw some people had problems and I’m not sure I’m technical enough to follow the directions
  • SQLite
  • **n8n EXECUTIONS_PROCESS setting: not sure
  • **Running n8n via Docker
  • **Operating system: Linux

Are you sure it does not execute? Because for me, it sounds like that you have n8n configured to not save successful executions, so once they finished after the wait they get deleted. Can you please check your workflow settings. Thanks!

Yes, I am 100% certain that it is configured to save successful executions. I have checked it about 30x in the last several days while trying to figure this out.

Additionally, the action that is supposed to be happening after the wait isn’t happening and I can see that in my logs of that tool, so I know it’s not executing by checking that as well.

Very strange. Did you try without the timeout?

I haven’t tried without the timeout.

Yesterday I copied the workflow and switched the “Wait - 1 Day” to 4 6-hour waits, and the first one to go through that version of the workflow just completed successfully. So I guess I’ll just leave it like that.

I have the same problem, using postgres.

Did you find the solution?

The solution I went with was using 4 consecutive 6 hour waits.

Has anyone found a plausible solution?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.