Webhook on server not working but working locally

Describe the issue/error/question

When I run n8n locally on my pc with tunnel on it allows me to receive trigger events from click up. However when I run n8n on my raspberry pi on tunnel mode then connect to it through my main computer using the port. N8n works fine for everything except receiving webhook events (webhook url from server pi: https://scrnnb1ap4yroju9inh4esba.hooks.n8n.cloud/webhook-test/dc7f6b8f-cca3-4815-a542-3a229a1b18d8/webhook).

What is the error message (if any)?

When I try opening the url it gives me a 504 time out error.

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: npm
1 Like

Hey @Stifling1488, I am sorry to hear you’re having trouble.

Unfortunately, I was not able to reproduce this based on your description, but if you’re simply trying to send webhooks inside your local network you can simply replace the tunnel URL with the IP or hostname + port of your machine. So instead of https://scrnnb1ap4yroju9inh4esba.hooks.n8n.cloud/webhook-test/dc7f6b8f-cca3-4815-a542-3a229a1b18d8/webhook, you could try http://RASPI:5678/webhook-test/dc7f6b8f-cca3-4815-a542-3a229a1b18d8/webhook.