Webhooks not working

Test webhook will not catch data. When I test the webhook and listen for test event nothing happens when I send data to the webhook. I have saved the workflow to activate the test url and its still not catching any data. I can not stop the test either by clicking the stop listening button does not work.

Information on your n8n setup

I setup n8n on digital ocean with a one click install from another user.

Can anyone help?

Welcome to the community @Astronautjones!

Are you for sure sending a POST request, not a GET one, to the Test Webhook URL?

Because to ~95% is the problem either the wrong method or the wrong URL?

Hey @jan. Thanks for the warm welcome! I am excited to be here and learn more. I am send a post request to the webhook.

Glad to hear, and great to have you with us. So then, let’s try to get to the bottom of this.
What is the response to that POST call?

I receive * {“message”:“Workflow was started”} from the webhook. But I do not see the test data I sent to the webhook. The module is still listening and when I try and stop the trigger it does not respond.

How did you set up your n8n instance? Did you follow our server setup guide? What do you use as a reverse proxy?

I became aware of the platform a few weeks ago and saw a video guide on setup. The video gave a link for a one click setup with digital ocean. It created the n8n app and database automatically for me. Then I was able to create my master user and login to the instance. I have only tried testing a workflow with a webhook. I have connected to other applications I use like stripe and high-level.

Can you please share a link for the set up guide?

Uh very sorry, totally forgot that you also mentioned that already in your first post.

Here is the guide for Digital Ocean:

I was asking because we had quite some issues in the past where the reverse proxy was not configured correctly, which then resulted in events from the backend not making it to the frontend.

Ok. I think this is what is happening. The reverse pros is not configured correctly. How do I fix?

That depends on the reverse proxy, there are very many different ones out there.

Generally, just delete/reset your droplet and follow the above guide. That probably takes ~10 minutes, trying to fix what you have right now will to for sure take muuuuch more time.

Did you set up n8n again via an officially supported way as mentioned above?

Got it loaded and working.

Glad to hear! Have fun!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.