Workflow could not be activated

So i’ve been using n8n fine for a few weeks. Over the past couple days I started getting some error messages when saving workflows or trying to activate workflows.

When I try to activate workflows I sometimes get the following error.

When trying to save a workflow I sometimes get the following error

This second one is not possible because I am the only user on this server and only have one instance open when this error is firing.

I run using docker-compose with n8n version 0.201.0

I am able to sometimes stop it from happening by restarting the n8n and postgress servers with docker-compose restart

I have docker-compose logs while triggering the errors to see if any errors showed up but nothing.

Anyone got any idea of what may be the cause of this errors?


Hi @dejecj

The first one I have never seen.
The second I have seen when opening a workflow in 2 tabs, since the new UI it seems to be less permissive when saving.
Luckily we can copy the whole workflow refresh the page and paste it back in. It can be annoying though.

@BramKn Well that was my thought on the on the second one. Which is why while troubleshooting I closed every browser window except the n8n editor and was still getting the error for some reason. I also think the errors might actually be related. I just tried again after restarting. I am able to save the workflow without issues but as soon as I try to activate and get the hash error the workflows stops being able to save until I refresh. Might be updating something in the backend when it tries to activate which is not being reflected in the front-end causing a de-sync and throwing the error.

I guess figuring out the hash error will be he resolution to both in my case.

Yeah the closing of tabs wont work. it holds the workflow somewhere even after closing all other workflows I think.
We will see what the n8n team has to say about it. :slight_smile:

Please fill in the setup information template, though. As it will help them find the issue.

Hello, we encounter the same error message “No entity column hash was found”, and cannot activate our workflow.

Thank you for your help !

Installation : docker-compose with n8n version 0.201.0

I also got this No entity column hash was found error. The workflow could be saved correctly. I managed to find out that the webhook node that i have in this workflow, used the same endpoint as other workflows. At the moment i changed the webhook endpoint url, the “hash” error message disappeared and i could activate the workflow

Hi @dejecj,
we released a new n8n version 0.202.1 yesterday including a fix for workflow activation.

@tpatulacci @sl-tobe
Could you upgrade your n8n instance to 0.202.1 to see if this fixed your issue.

1 Like

Hey all,
while you can try with the new update for sure, I am not sure it will solve the original problem which looks to me requires a DB migration. The error message says that the hash column is missing and that is something we added recently, so I guess DB schema has to be updated but I don’t have much more context than that.
Hopefully this helps.

EDIT: About the second error (Workflow saved by another user), this should definitely be resolved in the latest release.

@milorad @marcus Thanks. I ended up doing both of the suggested steps. I basically deleted my n8n instance database and all (after exporting my workflows). Then started from scratch with version 0.202.1. I have not seen the errors since. It was definitely a pain getting all my workflows back in and re-adding all he missing credentials (would be nice to have a more fluent way of doing that). But after all that the issues seems to have been resolved. Thanks.

1 Like

hi, I have been testing on 0.202.1 before i raised this issue, so it is not fixes by this release

We have updated to 0.202.1. At first I was not able to activate the impacted workflow.

But after I deleted the trigger node, and re-created it (without modifying other nodes of the workflow), I was able to activate it.

My workflow is working again. Thank you @marcus @milorad !

Arf, the error is coming back again. It re-appeared after I added the webhook-test-url to Gitlab manually (webhook url for production were added automatically to Gitlab)

@tpatulacci Ah, that’s a shame.
If the error you are facing is the hash column not found, then it makes sense it’s still not gone, since it’s a DB sync problem (your old DB table is not having newly added column).
If you are having trouble with Workflow has been saved by another user, to my best knowledge this should be resolved in the next release.

Hi, the error I get is “hash column not found”. I do not have “Workflow has been saved by another user” anymore.

Once I updated to 0.202.1, I then re-created the trigger nodes of my workflow. And it worked again.

But, once I added a test webhook url on Gitlab (urls I got from n8n), the error “hash column not found” came back (the 2 events seem to be linked even if i cannot be sure). From then, I cannot save my workflow anymore, even if I recreate my trigger nodes.

Why should I do to sync the DB ?

Thanks a lot for your help !

When I simply change the name of my Trigger node, I am able to activate my workflow

The Hash column was added in a recent update. So changing the workflow and saving it would trigger it adding this column if it doesnt exist, I guess.

got this issue on the latest version 0.202.1 while using strava trigger

Screenshot from 2022-11-15 09-44-11

I do encounter this ‘No entity column “hash” was found.’ as well, but on the Hubspot trigger node.

Using the docker version. Is it really necessary to delete everything and start from scratch with the DB? I have a lot of active workflows running so it’s a bit of a pain.

try moving the node and saving the workflow.

Thanks but it doesn’t work, I need to either disable it, disable the workflow or delete the node for the error message to disappear.