Zoho Authentification Error (Oauth)

Hello, I’m trying to connect Zoho CRM with N8N.
I’m using cloud, I have followed that doc Zoho credentials | n8n Docs
What I understand from the disclaimer for cloud users at the top of the page is just follow N8N path

So this is basically what happens:

  • I start on the node in N8N
  • I then log in with my Zoho Account
  • I choose the right org (prod)
  • I accept the message (these are the credentials needed etc…)
  • I land on that error message : {“error”:“invalid_code”}

I checked with Zoho support which direct me toward you guys ^^
Do you know how I could successfully plug those 2 tools ?

  • n8n version: : Cloud Version 1.1.1

Thanks a lot for your help !

Hi @Damien_Busch :wave: Welcome to the community :tada:

I’m not having any trouble connecting to Zoho :thinking: Is your access token URL set to the correct datacentre? Could this also possibly be a permissions issue within your organisation?

Hey @EmeraldHerald thanks for taking some time to answer !
I think I’m an Admin in Zoho, but not a Super Admin, do you know if it’s mandatory connect ?

Hi @Damien_Busch - I don’t think it will matter that you’re “only” an admin, as it looks like the main difference between admin and super admin is the latter is the owner of the workspace as a whole. You still have all the permissions you should need as an admin.

Can you double-check if your region is correct? I’m still not able to get the Zoho connection to error out unless I select the incorrect region :thinking:

OK you were right, the datacenter was the problem.
I choose US (because we sell in the US), but the datecenter is EU → now it works fine.

Thanks a lot !


Glad to hear you got this sorted!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.