401 unauthorized Clickup integration Oauth2

I’m running n8n on docker on a custom subdomain and wanted to use the Clickup Oauth2 credentials to connect n8n with clickup.
The n8n workflow is saved and active

I tested initially by using a webhook URL trigger to check if it would work and it does execute the workflow.

When I use an access token it works, and I can select the workspace, folders, etc. but how does the trigger get triggered ?
I created a * event trigger as below but the workflow does not execute
image

I then tried to add an app in Clickup and use Oauth2 but when I click Connect OAuth Credentials and I select the workspace and Save, I receive the following error in the n8n logs and Oauth fails to connect

n8n_1 | (node:6) UnhandledPromiseRejectionWarning: Error: HTTP status 401
n8n_1 | at /usr/local/lib/node_modules/n8n/node_modules/client-oauth2/src/client-oauth2.js:283:25
n8n_1 | at processTicksAndRejections (internal/process/task_queues.js:93:5)
n8n_1 | at async /usr/local/lib/node_modules/n8n/dist/src/Server.js:878:32
n8n_1 | (Use node --trace-warnings ... to show where the warning was created)
n8n_1 | (node:6) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see Command-line options | Node.js v16.2.0 Documentation). (rejection id: 2)
n8n_1 | (node:6) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

I tried with a new docker container and --tunnel and I get the same result while using the n8n.cloud

Not sure I understand. You say it is also not working on n8n.cloud for you? I just tested with new credentials and they connected just fine and they also worked then in combination with the node.

So can you please say where it works and where not?

  1. n8n.cloud
  2. Docker container with tunnel
  3. your own server with a custom subdomain

If it works for 1 & 2 but not 3, then I would check if your subdomain has a valid SSL certificate and if the OAuth credentials are correct.

I tested again now also and it worked directly.
Maybe it was a temporary problem

@jan Is there a time when the trigger is being executed?
When I execute the workflow manually it gets the task creation and the workflow is starting but when I don’t execute the workflow myself, I don’t see the trigger doing it’s job

Glad to hear that it works now!

If the workflow is activated (via the toggle in the top right corner) it should start that workflow every time the selected event happens in ClickUp.

Important to know:
You will only see the data in the editor-UI if you run the workflow manually. If it is running in production mode (when the workflow is active) it runs only in the background. Meaning you will only see that it did run in the Execution List (at least if you have it set to save successful executions).

Hope that helps!

@jan Thanks for the reply.

That was a very important piece of information !
The execution list was not saved, so I thought that it was not executing.
I see it working and it is triggering every time.

The default settings are not saving the executions.

Glad to hear that it helped. Have fun!