BUG: After update can't see executions anymore

Hello, I was in version 0.199.0 (two versions behind the current version).

After updating to the last version: 0.202.1

I can’t see the executions anymore!!

It shows a spinning that loads infinite and nothing shows up:

It happens with every workflow and all the executions.


If someone needs to downgrade:

docker pull n8nio/n8n:0.199.0 (use the needed version)


image: n8nio/n8n:0.199.0

1 Like

Hello @yukyo
I am sorry to hear that you cannot see any of your executions anymore.
Before we dig deeper into the problem, is there a chance to go back to 0.202.1 and check are there any errors in your browser console when you switch to the Executions tab?

1 Like

Hi @milorad.

I upgraded again to the last version, and the problem is still there:

I hope it helps.

Thanks @yukyo that certainly helps.
Since I am unable to reproduce it still, can I ask you for one more thing? Can you click on on the link in the error (the one labeled companion-bubble.js:1465) as send me the screenshot of the part of the code it takes you to?

This one:

Hey guys I have similar experience after upgrading to 0.202.0 or 0.202.1, although with 0.201.0 everything works fine.

The execution data doesn’t load with the newest version and I need to login to n8n every time I open the editor.

Console log

Error points to

1 Like

Hi @yukyo,
sorry for not getting back I was waiting for your follow up on my latest post.
That error message points to the companion-bubble library which, to my best knowledge, is not part of n8n. Could it be that some of the browser extensions that you are using is causing problems?
There is also this thread that seems familiar to this problem.

1 Like

I can confirm that we are able to reproduce this internally. Hopefully we’ll have a quck fix. Thanks for reporting.

Hey all,

So far it seems that the cause is gone with the newest update [email protected] or 0.203.1


@milorad, I can also confirm that it is working now with the last version on my side. I downgraded one more time to the issued version 0.202.1, and again was not working, so something in that version is causing the issue…

Now it seems to work with the last version 0.203.1

However, if it helps, I still see the console log error:



Hey @yukyo,
thanks for getting back on this, glad to hear executions work now, we’ve made a number of fixes for it based on your guys feedback.
As for this companion-bubble error, to be honest, I am still not sure where it comes from other that some browser plug-in, as I’ve written somewhere here before.

1 Like

Hello :slight_smile: this is somehow not fixed for me yet.
I freshly updated to 0.209.4 and can’t see my executions anymore.

the executions-current endpoint returns an empty data object, the executions you can see in the screenshot, i tested also with the chrome browser.

Hey @FirePanther,

Is there possibly a lot of data in the database? If you go to to the execution view on the left does it show the executions?

Hey Jon, thanks for you really quick reply.
I tried it out with different workflows, today I even truncated the executions table, this means I started the executions completely from scratch, so even if I have only one single execution, it doesn’t show me anything.

Before someone sees my “really quick reply” and thinks “passive aggressive sarcastic person” :smiley: it’s because I freshly created this topic: Bug: After update no details of executions anymore and actually got a quick reply

:joy: Normally we are a lot quicker than 5 days. It looks like this is being handled on the other thread though so this one can continue there.

1 Like