[BUG] MailerLite nodes returns wrong subscriber ID

Already tested with two different n8n instances, in different machines.

Whenever I use MailerLite nodes to create or get subscribers, the subscriber ID in the response is wrong.

Example subscriber IDs
Correct: 113280109331350776
Wrong: 113280109331350780

It also returns the wrong group ID when searching a subscriber by email. If I want to know to which group ID the subscriber belongs to, I won’t be able to because of the wrong ID.

Example group IDs
Correct: 113276040087864466
Wrong: 113276040087864460

I can confirm this issue by making a custom HTTP request, which returns correct ID values.

Outputs

Information on your n8n setup

  • n8n version: 1.27.2 and 1.27.3
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own, main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: Ubuntu 22.04

Hey @gmsalomao2,

I suspect the issue here will be that the number is larger than NodeJS can handle with its default number type and we will need to put in a fix to work around that.

I will get a dev ticket created on Monday when I am back to look into this.

2 Likes

Thank you, Jon. That’d be really helpful :pray:

still not fixed! It makes Mailerlite unusable for me :man_shrugging:

Welcome to the community @Lismont

Sadly the team is very busy with all kinds of things so things like this can take a bit of time to get solved.
I see there is a workaround by using the HTTP node, have you tried using that?
If you cannot get it to work, please post a new topic with where you are stuck and someone can help you get this workaround going. :slight_smile:

using http node is not solving the issue.

It is a workaround that seems to work. So yeah it is solving the issue in the short term.
The actual issue with the node of course also needs to be fixed, but you can continue your automations with the HTTP node.

ok, got it. thanks

For now we can only rely on the custom HTTP requests =(

If you are having trouble with a custom request, I can provide you with some examples I’ve been using.

It looks like we use the old Mailterlite api as well so we really should update to the newer API which will fix this.

1 Like