Clickup Node Assignee on task creation through expression

Describe the issue/error/question

I’m trying to create a task in clickup through the n8n integration. If I choose the assignee from the dropdown list everything works fine and the task is created with the correct user.

But If i try to use the assignee from an expression, the task gets created but not assigned.

These are the following input styles I’ve already tried.

55470041
[55470041]
[[55470041]]
[Array: [55470041]]
[Array: [‘55470041’]]
{{ [55470041] }}

This ticket is somehow similar to this one: Clickup node assignee - #12 by Reid , but as suggested from @Jon I’ve started a new topic here.

What is the error message (if any)?

No errors found

Please share the workflow

Share the output returned by the last node

This is the response from clickup where you can see that there is no assignee attached:

image

Information on your n8n setup

  • n8n version: 0.169.0
  • Database you’re using (default: SQLite): mysql
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hey @pointia,

You are using { { [ {{$node["Config"].json["GitLabToClickUp"][$json["assignee"]["id"]].id }} ] } } for the expression so it could be that the data you are sending is the issue. Can you share hte outpu tof the config node and the node before the clickup node?

Hi, thanks for your quick answer.
The expression resolves just fine, so the output is (depending on the configuration) always the same.

e.g.
55470041
[55470041]
[[55470041]]
[Array: [55470041]]
[Array: [‘55470041’]]
{{ [55470041] }}

Here is the output of the previous node:

This is the output of the Config Node

Hey @pointia,

I have just made a click up account and my users ID is 44405069 if I create a task and set the assignee to {{[44405069]}} it appears to be setting the value correctly.

Using the variables from previous node if I use {{ [ parseInt($node["Config"].json["GitLabToClickUp"][$json["assignee"]["id"]].id )] }} it appears to be working, I removed the space between the {{ and also added parseInt as it expects a number not a string.

1 Like

Thank you very much, now it works like a charm!

For the future, I think I might have to specifically check which type the input is that is passed.

1 Like