CSV spreadsheets with delimiter ;

Hi,

we search a solution to export and mail data in CSV format with the delimiter “;”.

Context: The spreadsheeet node only knows the delimiter “,”.

Does anyone have a solution or suggestion?

Enjoy the summer,

sxlabs

Hi @sxlabs, welcome to the community :tada:

The Spreadsheet File node can read (most) files using ; as a delimiter just fine, but would indeed not be able to produce such files currently.

So I’ll convert your question into a feature request, allowing you and other users to vote on having this implemented.

In the meantime, you could consider workarounds such as manually writing your CSV file using a bit of code, then converting it into a file. Here’s a quick example doing this:

This example returns a CSV structure using ; and looking like so:

id;name;email;notes;country;created
23423532;Jay Gatsby;[email protected];Keeps asking about a green light??;US;1925-04-10
23423533;José Arcadio Buendía;[email protected];Lots of people named after him. Very confusing;CO;1967-05-05
23423534;Max Sendak;[email protected];Keeps rolling his terrible eyes;US;1963-04-09
23423535;Zaphod Beeblebrox;[email protected];Felt like I was talking to more than one person;;1979-10-12
23423536;Edmund Pevensie;[email protected];Passionate sailor;UK;1950-10-16

Hope this helps!

2 Likes

Thank you.

1 Like

Hi at all.
@MutedJam your suggestion looks very interesting to me. But i havent an node called create binary item. Only Move Binary Data ist available, or write Binary File.

This is my actual workflow.
Some suggestions?
Thank you.

My n8n instance is an docker image on an unraid server, which works almost perfectly.

Hi @daju, welcome to the community!

The node is called Move Binary Data, I’ve simply renamed it in my flow to describe what it does :slight_smile:

You can either add a new node through the UI or you could simply select in from my workflow here on the forum, then use Ctrl+C to copy it and Ctrl+V on your own n8n canvas,

Hope this helps!

Hi @MutedJam. Yes i tried this first, before i posted here.
Thank you. now i’ closer to the solution.
But my csv file looks like this:

{"csv_content":"Email;Kndnr\[email protected];101316\[email protected];......

looks a litte weird.

It shoul look like this:
Email;Kndnr
[email protected];425636
[email protected];4565663

and so on.
But the delitmiter look fine now.

This sounds like the options you are currently using on the node might need a little more tweaking. Have you disabled the “Convert All Data” option and added the “Use Raw Data” option as shown below?

i see my mistake. forgotten to uncheck convert all data.
i also checked Always Output Data in the settings.
But my item is empty.

Ah, it seems your Source Key value is an expression rather than the actual name of your field holding the data. Can you try replacing your expression with just csv_content (no curly braces or anything)?

yes i figured it while waiting on your response.
Thank you sooooo much @MutedJam .
Your help was awesome.
Best wishes…
:smiley:

1 Like

Glad to hear this helps, thanks so much for confirming :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.