Error executing hubstop trigger

Describe the problem/error/question

I created a hubspot trigger node and successfully got the credentials to connect.

However, when I execute the node I get an error.

What is the error message (if any)?

Problem running workflow

Bad request - please check your parameters

Show Details

When contact created: Target URLs must start with ‘https://’.

Please share your workflow

Share the output returned by the last node

Error as above with the first node, hubspot trigger.

Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): sqlite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): unknown
  • Running n8n via (Docker, npm, n8n cloud, desktop app): executed from CLI
  • Operating system: Linux

Hi @ebdavison, welcome to the community!

Is there a chance your webhook URLs are insecure http:// URLs, something like http://localhost as shown below?

image

If so, you probably need to set the WEBHOOK_URL environment variable to your public n8n URL using https (and also make sure you have a valid SSL certificate).

Well, indeed. The webhook URLs are http, not https. I will need to look into that environment variable and restart n8n. I will let you know how it goes.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.