Error When running n8n:latest

When deploying a container with n8n:latest I am getting an error on multiple environments. When setting the latest version to 192.2 it works.

[FATAL tini (8)] exec / failed: No such file or directory

On Docker with Postgres

Sorry to hear that you have problems @BramKn!

Can you please tell me how exactly you start the n8n docker image so that we can reproduce the issue. Thanks!

Hi @jan
I use portainer (Docker GUI)


Other port because this is a 2nd container to test the issue. My original container on this environment is still runnning and working. (will stop working when restarting the container, that is what happened at an other environment)

So what happened was, that an environment crashed for some reason unknown. And when Docker restarted the container (always with the latest version) It didn’t start anymore.
When putting in the latest version(192.2) it starts fine again no issue at all

So I tested it on my own mess-around environment, duplicating a container and starting it with the latest version. And get the exact same error as with the other environment.

I see the latest version is now 193 and this was released 15 minutes before the server crashed. that can not be a coincidence.

Can you please also check if you are passing in any custom cmd or entrypoint ?

Also, do you see the same issue if you start the container from the command-line with docker run -it --rm n8nio/n8n:latest ?

Adding 193 as a specific version also breaks it.

Default entrypoint Portainer? sets


We did significantly change how we build our docker images in the 193 release. So, it’s very likely that we broke something.
Unfortunately I can’t reproduce this on my local portainer.
I created a new container with n8nio/n8n:latest, and it works as expected.

What version of portainer are you on? and what OS are you running?

I havent tried a fresh container. Will do that as well to check.
On new laptop though so need to grab some stuff from cloud before able to login and stuff. :sweat_smile:

portainer 2.9.3 on both tested environments running in ubuntu Cannot see the specific version at the moment. (default Hetzner Install on both)

I Checked with fresh install with no volumes attached and this does work. on latest

^ We changed the entrypoint from / to ./
This sounds like your setup is somehow still using the old entrypoint.

Ok, so as soon as I attach a volume it breaks.
Newly created volume Fresh Container.

Oh A different error now on this new container with fresh volume:

Might be my dyslexia but I do not see a difference in before and after for the entrypoint.

The old entrypoint was at the root of the filesystem (/), the new one is in the workdir (./). It’s a relative path now.

Ah missed the . :sweat_smile:

here it does have the new entrypoint though:

Don’t understand why the new container with a new volume does not seem to have access to that volume.

I’m not sure about that either. But we did change from running n8n as root to as node user.

Both these issues have been addressed here, and an updated docker image should be live in the next hour.

1 Like

Awesome thanks a lot!

Will be waiting for it and report back when installed.

1 Like

is it 193.1?
Timing doesn’t seem quite right :sweat_smile:

we released a 0.193.1 less than hour ago, and decided to override the tag. Please wait another 30-40 minutes, and then pull in latest or 0.193.1 again.

1 Like

Ahhh, ok that explains a lot. Thanks again!

I needed to create a fresh container to get it to work. But could easily use old volumes and such so everything is working fine now with newest version.
Not sure why I needed a fresh container though.

1 Like