Error Workflow Triggered Even Though "Continue On Fail" Enabled?

Describe the problem/error/question

I would like to ignore errors from a specific node. Therefore, I enabled “Continue On Fail” in the workflow settings. However, the error workflow is triggered nevertheless. According to a previous answer by @MutedJam, this should not be the case:

Do “continue on errors” trigger the error trigger in any case?
No, errors are ignored when the Continue On Fail option is active.

Is this a bug? Was the previous answer wrong? Is there any way I can achieve this? I would still like to catch errors from other nodes in my error workflow. I would just like to ignore errors from this specific node.

What is the error message (if any)?


Please share your workflow

Share the output returned by the last node


Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): n8n cloud
  • n8n EXECUTIONS_PROCESS setting (default: own, main): n8n cloud
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: n8n cloud

Hi @simon.sprankel, I am very sorry for the trouble. Is there a chance you’re seeing a “no data” error, similar to what @GBOL has reported over here?

This behaviour has unfortunately changed with v1, and while we will work towards making this configurable based on the feedback we’ve received so far, this will take a bit to implement :frowning_face:

Thanks a lot for your feedback, @MutedJam. Actually, I thought this issue also happens with n8n 1.. However, it looks like the update from 0. to 1.* (which we did just yesterday) fixed the issue for us. Now, the error workflow is not triggered any more for errors, which happen at a node with the “Continue On Fail” setting.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.