Errors since last n8n update (1.44.1)

I recently updated my n8n to version 1.44.1, Since then, I have been having issues with some credentials and workflows
Eg, The airtable credentials below were working correctly on the previou sversions but currently do not work. I have tried recreating that using both an access token and auth but its not working. Same for WordPress

The other issue is with HTTP / connectivity. When trying to send http requests to some applications, I get the following errors: How can handle this?

I am running n8n on windows docker with a PostgreSQL database. (This is a new, clean installation.)

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Imperol! What version did you update from?

@Ludwig I was using v 1.42, and updated to 1.44.1 on docker sqlite db. Once Ipdated I started getting the errors and had to set it up wit a postgres db

Actually, seems there is some issue with the network connectivity. Can you check that is working?

I’m experiencing the same issue since the update. I am getting ETIMEDOUT errors on popular services like Telegram, MS To Do, and others.

Other applications have been failing too eg wordpress, http requests etc.

1 Like

Up i get same problem and stuck because when you rollback this error still exist

Telegram cant add any credential

1 Like

I have the same problem with update to the latest.

1 Like

Any update about this? its still not solve with new version

Same problem for me, timeouts on the Telegram node

I managed to fix it, by forcing node.js version 18.17.0 you can install different node versions using nvm (node version manager).

Here are the steps (i’m using NPM install on Debian, so for docker it might be different):

  1. Install nvm
sudo apt update 
sudo apt upgrade
sudo apt install build-essential libssl-dev
curl -o- | bash
  1. Install and activate Node.js 18.17.0
nvm install 18.17.0
nvm use 18.17.0
  1. Set 18.17.0 as the default NVM version
    Sometimes NVM will use a different version of Node,js as the default, so it will revert back to it if your computer/container/VM restarts. You can set the default with this command
nvm alias default 18.17.0
  1. Update pm2 env variable
    If you are using PM2 to run n8n, you will need to also run this command
pm2 restart n8n --update-env

Now if you run

pm2 describe n8n

You should be able to see that node.js version for n8n is set to 18.17.0

Hope this is helpful to somebody :slight_smile:

I suspect that this issue might be related to n8n not having keepAlive enabled by default for external requests, and some networking defaults in the nodejs changing recently, changing the traffic volume levels at which this error occurs.
If your application is making a lot of calls to one specific API (like Telegram), then you’d see this issue on almost all versions of n8n, depending on the volume of API calls.
If this is the case, then the upgrade to nodejs 20 might have worsened the situation, but it wasn’t what introduced the issue.
This could also explain why downgrading did not fix the issue for @tridi

To validate if this really is an issue of high volumes of API calls causing the system to run out of sockets, or the upstream rejecting new connections, I’ve created a branch based off 1.44.2, with keepAlive force enabled for all http calls.

Also created a docker image from this branch, available at n8nio/n8n:enable-keepAlive.

If any of you can please switch to this docker image, and let us know if this resolves the issue for you, I can create a proper PR.

hi @netroy thanks for the reply

ive tried your branch but the error still happen just on telegram node

I also create another thread about this Telegram Node Error connect ETIMEDOUT - #3 by tridi and the solution for now just force fresh install with version 1.42.1

Those errors unfortunately seem to remove any meaningful details because of some of the recent changes around errors.

Can you please try this workflow (replace [[YOUR_TELEGRAM_TOKEN]] with your bot token) to make a direct http call to see what error you get:

its still error on telegram API only but for another endpoint its no problem

connect ETIMEDOUT | connect ENETUNREACH 2001:67c:4e8:f004::9:443 - Local (:::0)

its show more info for the error like this

Thanks for checking. That looks like something is blocking the network calls.
Maybe it’s only blocking IPv6, and you could try forcing IPv4 by adding this env variable to the docker stack: NODEJS_PREFER_IPV4=true
If that does not work, I’d recommend investigating what’s blocking the traffic to those IP addresses from your host.

You can also check if IPv6 calls to telegram are getting blocked by running curl -v6 on the host machine.

already add NODEJS_PREFER_IPV4=true to my env and still not fix this problem.

for your another suggestion i guess i dont know how to investigate it but if i force delete all this n8n docker config include the volume etc and config with new config on version 1.42.1 its solve this problem.

is it still because my server ban those IP address?

ive tried your curl command on my stable n8n with version 1.42.1 its show block telegram API but actually its no problem at all if i hit telegram API on n8n also on when filling new bot credential


Looks like Telegram itself has some issues on its IPv6 address.
This is likely triggering a nodejs bug.