Google Sheets API CONNECTION

Hi:

Do you know why this error is generating for? & why there is no option to change to OAuth 2.0?

Welcome to the community @Ruta_Covid!

That is a sign that you did not format the private_key correctly. Please make sure to replace all \n with a new line as described as step 11 here:
https://docs.n8n.io/nodes/credentials/Google/#using-service-account

1 Like

Hi,

I corrected the “\n” but still i am getting the below error:

ERROR: 403 - {“error”:{“code”:403,“message”:“The caller does not have permission”,“status”:“PERMISSION_DENIED”}}

StatusCodeError: 403 - {"error":{"code":403,"message":"The caller does not have permission","status":"PERMISSION_DENIED"}}
    at new StatusCodeError (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/errors.js:32:15)
    at Request.plumbing.callback (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/plumbing.js:104:33)
    at Request.RP$callback [as _callback] (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/plumbing.js:46:31)
    at Request.self.callback (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:185:22)
    at Request.emit (events.js:310:20)
    at Request.<anonymous> (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:1154:10)
    at Request.emit (events.js:310:20)
    at IncomingMessage.<anonymous> (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:1076:12)
    at Object.onceWrapper (events.js:416:28)
    at IncomingMessage.emit (events.js:322:22)

I believe if the sheet name is “https://docs.google.com/spreadsheets/d/1KD8fMFpuA9dKSYsGgTNv0BSKVdkUkA9-ilKvHyJY46Y/edit#gid=0

then sheet id is “1KD8fMFpuA9dKSYsGgTNv0BSKVdkUkA9-ilKvHyJY46Y”!

Screenshot 2020-08-20 at 1.37.56 AM|690x351

Hey, @downlz welcome to the community.

Make sure the sheet has permission for the current user. You can check that with on the top left side of the sheet, check the image below. I’m guessing you used the service account authentication. If so, add the email you used there as a user under the share option.

Hope this solves the issue. If not, simply get back to me.

image

1 Like