Google sheets append not working


I am new to n8n. So far I love it, however I can’t seem to get the append function to work in google sheets. The read function works fine, but writing seems to be an issue. I have looked at videos and it just isn’t working for me.

The authentication I’m using is service account and not Oauth2, is that the issue? If not, any help would be appreciated.

Also when I run the append node, google sheets is saying “Last edit was seconds ago” but I don’t see any update?


Welcome to the community @Tomas_Wooller-Bailey!

The first two things that come to my mind would be:

  1. Does the data you “send” into the node have keys with the same name as the columns in the Sheet?
  2. It always appends the data after the last totally empty row. So if there is somewhere a row anywhere with some data it appends the data after that one. So it maybe gets appended but you simply do not see it as it is so far down.

Is there a way to append data to a new column not new row?

Hi @Unashe_Siwawa and welcome to our community :wave:

The Google Sheets node is not designed to change the data structure of a Google Sheet, so currently is not possible to add a column.
What is your use case? Why do you need to add a new column?
I’m asking since maybe I can come up with a different strategy, and also because I’m always looking to understand the actual use case of our users


Hi @giulioandreini ,
Thank you, for the quick response, I actually find a way to do what I wanted, it was not to add a new column, but to add new information in a specific cell, that was empty before,

Thank you so much!!!

1 Like

Glad to hear you solved your problem @Unashe_Siwawa !
Let us know if we can help in any other way and happy n8n’ing :slight_smile: