Google sheets node execute not ending

Am executing the Google sheets node after configuration, something seems to have gone wrong. The workflow execution is not ending. Tried stopping the execution. But doesn’t seem to work.

Screenshot 2021-06-14 at 10.43.55 PM

I had to exit n8n and login again to stop it.

Hey Ruchika,

Are you using any Trigger nodes in your workflow? It seems that the workflow is waiting for the Trigger node to get executed. Can you please let us know if you’re using any trigger nodes?

I can also notice from the screenshot that you shared, the Google Sheets node is not connected to the workflow. Hence, to execute the node, you will have to open the node and click on the Execute Node button. If you click on the Execute Workflow the whole workflow gets executed (all the nodes that are connected get executed).

Actually I had tried the node as part of the workflow too and then separately. Both the cases it kept spinning. I think the screenshot I added was wrong.
When I run a “Read” on the Google sheet, it does that. I did a Lookup and it worked fine.

May I know how many records does the Google Sheet has? The node might be making some time if the number of records is huge.

Hi @ruchikaabbi! It would also be helpful to know which version of n8n you’re on. You can find that out by going to ‘Help’ (in the left menu) then ‘About n8n’

Yes, the number of records is quite high…