Heroku webhook 404 error

Hello I deployed N8N on Heroku by following the “one-click” installation of the documentation at this address: Heroku | n8n Docs

N8N displays correctly but I have a problem:
My Webhook returns a 404 page in both development and production. I tried to send it data in POST it doesn’t work and I tried in GET on my browser and I get a 404 page.

Here’s what I get:

Here are my environment variables on my admin Heroku:

I’m lost. Do you have any idea what the problem is ?

N8N Version is : 1.8.2

Hi @RemiDpr, I have not unfortunately. Can you confirm under which URL you access the regular n8n UI? Is this any different from your WEBHOOK_URL?



I access the UI on: https://remidupre-8dc8bca5359f.herokuapp.com/

My test Webhook url: https://remidupre.herokuapp.com/webhook-test/322467c1-6614-499b-a3a0-1db99ac98793

I noticed that the url is not there even. If I match the URLs it works… sorry to waste your time :sweat_smile:

So I need to change my WEBHOOK_URL variable in my Heroku admin?

Thank you very much for your help :heart:


Yep, pretty much! The WEBHOOK_URL should point to the public URL of your n8n instance. So setting WEBHOOK_URL=https://remidupre-8dc8bca5359f.herokuapp.com/ should do the job :slight_smile:

Afterwards, the webhook node should display URLs such as https://remidupre-8dc8bca5359f.herokuapp.com/webhook-test/322467c1-6614-499b-a3a0-1db99ac98793 which should work fine. Also, the WEBHOOK_TUNNEL_URL variable is not needed anymore, so you can simply remove that one to simplify things a little bit.

Hope this helps!


Thank you for your speed and help :slightly_smiling_face:


You are most welcome! Glad to hear this worked for you @RemiDpr!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.