HTTP Request API 400 - {"type":"Buffer","data"

Hi all. I’m having trouble with the HTTP REQUEST node …((((
I need your help, I’m trying to try different Rest APIs, but I encounter an error, for example, what is indicated in the service documentation and what I enter and what error I get:

Hi @FIRE_TIKTOK, this suggests the response from your webserver doesn’t actually contain binary data but instead you’re seeing the buffer representation of an error message sent by the server.

Could you try switching the response format to string temporarily and see if you might be getting a more useful error message?

Now it gives this error…

Please help me((( I broken my head

Hi @FIRE_TIKTOK, the error “Please set url to the link to a source file or upload a file and set as a source” is an error coming from the system you’re sending data to.

From looking at Upload Files | API, it doesn’t look like your endpoint accepts binary data directly.

The file upload process itself seems to be a multi step process. First, you’d need to “generate the secure URL for upload” it seems. Only then will you be able to send your binary data to the generated URL.

It seems to be me that only once you have followed the above steps you’ll be able to perform the conversion using the previously uploaded file.

But this is something the support team of the service you’re calling can clarify if you have any doubts here.

Thank you for the answer, I didn’t think that this service would have such difficulties)) The problem is that I think that this error haunts me :))) I tried to use some RapidApi services, but I get the same error as soon as I try to use some Rest API, then…(
I saw here on the forum that the same problem was, because “Cookies” were not registered in the headers.
P.S. And another question, if I get the name and value of Api , do I correctly set them in the Header (Credential)? Or is the authentication method different? Thank you in advance for your response