[HTTP Request - timeout of 300000ms exceeded] Can I extend timeout?

Describe the problem/error/question

Is it possible to extend the timeout threshold of an HTTP node?

I have this error Problem in node ‘HTTP Request‘ - timeout of 300000ms exceeded. I am calling OpenAI Completion API which indeed, can take up to 45min.

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: ai-beta
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system:

Hi @Kevin_Lourd :wave:

It looks like you’re sending quite a fair bit of data at once - can you try smaller batches and see if that helps with the timeout? If a lower limit doesn’t help, you can configure the timeout in the node options:

1 Like

I’ve got the same issue here. The connection between n8n and OpenAI seems to disconnect after a few minutes of waiting for the output, even if the timeout is set to one hour.

Sometimes I get this error: ERROR: The connection to the server was closed unexpectedly; perhaps it is offline. You can retry request immediately or wait and retry later.

Thank you for the support @EmeraldHerald!

I solved the issue by adding a loop on my linear workflow, with batches of 1 item at a time :+1:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.