I'm unable to run the GitHub code locally (on the MAC and ubuntu OS)

Hello everyone!
great community!

i have a problem installing the n8n system.
when i use the npm or docker, i’m able to install it and the system works fine.
but when i install directly from the github code, i get an error.

i follow this instructions:

when i run “lerna bootstrap --hoist”

i get this error:


node version - v16.11.0
npm version - 8.0.0

Hey there @koraal,

What version of Node and NPM are you using? I had a similar issue on my Mac and I ended up needing to use NPM version 6 to get it working.

oh, i just replied on the original post

node version - v16.11.0
npm version - 8.0.0

Can you try NPM version 6 and Node 14 and see if that helps.

thank you, i will try now and reply back.

its giving the same error…anything else we can try?

… notes from Discord chat

npm run clean:dist; rm -rf node_modules;

Make sure Node is version 14.

1 Like

Hey @koraal,

Are you still facing the issue? Let us know if you need help :slight_smile:

thank you, all is good