Issue when creating child row (many-to-many) with NocoDB

Describe the issue/error/question

I am having an issue when trying to create a child row in NocoDB using the NocoDB node. The NocoDB documentation (here) mentions that a child row can be created by POSTing to /api/v1/tableName/:parentId/childTableName, so I created a pattern that matches this in the “table” field of the node (tableName/:parentId/childTableName). The resulting table name I see is indeed correct, but when the actual request is made to NocoDB, /bulk gets automatically appended to the URL, causing the request to fail with Cannot POST to /api/v1/[...]/bulk. I have not figured out a way of preventing this. If I only use the child table name, without its parent and parent ID, the request is working properly.

Could that be a bug?

What is the error message (if any)?

Cannot POST to /api/v1/[...]/bulk

Please share the workflow

Share the output returned by the last node

        "property-count": "44"
        "property-count": "108"
        "property-count": "33"
        "property-count": "12"

Information on your n8n setup

  • n8n version: 0.169.0
  • Database you’re using (default: SQLite): (have not changed defaults)
  • Running n8n with the execution process [own(default), main]: (have not changed defaults)
  • Running n8n via [Docker, npm,, desktop app]: docker with docker-compose

I’m using endpoints for m2m table itself in HTTP node
It works well in my case


Ok that’s great, but that’s with the HTTP node, is there a way to make it work with the NocoDB node? Ideally I’d use that one and not the HTTP one, although that’s not a strict requirement.

Sure you can do the same opeartion with Nocodb node
You’ll have to specify that m2m table id and two respective fields to fill with related rows’ ids

In Nocodb you can enable showing mm tables in general list in Themes section