Issue with IMAP Email node not triggering on certain emails

Hi there fellow n8n-ers,

First of all thank you for building and maintaining this amazing piece of kit. It’s AWESOME!

So I experience some issues with the IMAP Email node on fetching mails with an attachment.

The setup is quite simple. I want to trigger a workflow on receiving an email with an attachment.

I have the node configured like so:

Let’s say the email address where message are inbound is orders ATcompanyDOTcom

So now I run this node and get the ‘Waiting for you to receive an email’ prompt.

Now when I use my gmail account to manually send an email to orders AT companyDOTcom it works perfectly! The workflow is triggered, the attachment is downloaded. GREAT!

BUT when I use my client’s ERP to send an email to orders AT companyDOTcom it doesn’t trigger and just keeps displaying the ‘Waiting for you to receive an email’ prompt.

If I then manually forward this message from the inbox of orders AT companyDOTcom to orders AT companyDOTcom, it DOES trigger the workflow.

Also if I run this library: imap-simple - npm and let it run their example simple_imap.js and keep it running it does automatically pickup the email.

Sadly, n8n’s IMAP node doesn’t… Oddly enough when I turn off the option to Download Attachments, it DOES work and trigger the workflow upon receiving the emails from the ERP.

Any thoughts on how to handle this issue are highly appreciated. Thanks in advance for your help!

bg

Jelle

ps: dummy email adresses have AT and DOT due to first post not allowing more than 5 links in post.

Information on your n8n setup

  • n8n version: 0.165.1
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker on DigitalOcean droplet, tried Desktop version, as well]:

HOLD THE PHONE!
I have just switched the format setting fomr Simple to Resolved and now it is WORKING! So for anyone ever struggling with IMAP node not triggering on emails with attachments, please check the Format setting like so:

2 Likes