N8n npm npx

Can somebody please explain to me, step by step, how I can install n8n via npm on macOS Silicon?

When I run npm install n8n -g, and the try to start n8n via n8n of n8n start, I get

command not found: n8n

I’ve tried with Homebrew/npm

And when I try to test it via npx n8n, I then get an old version …

[email protected] ~ % npx n8n
n8n ready on 0.0.0.0, port 5678
Version: 0.106.

And now that we’re at it, can somebody please also explain me how to install an extra package?

Thanks in advance and best regards - Dick

I don’t have a Mac to test this firsthand, but it seems you might have an old package cached somewhere. Could you try running npx [email protected], essentially telling npx you want the latest version of the n8n package?

2 Likes

Thanks Tom! This works. Tonight I’m going to do a clean install of Homebrew, npm and n8n to see if that works better as well.

Any advise what to do with npm WARNings and high severity vulnerabilities? Should I run ‘npm audit fix --force’ to address these issues ad advised by npm?