N8N Webhook Upload Limit

Problem:
When I try to upload files larger then 226mb to a n8n webhook the data gets truncated off. Is there any limit that i can set?
I tried uploading files with 204mb and smaller and there everything works. But If I upload larger files the request body is only filled with the parameters before the uploaded file.

What is the error message (if any)?

No there was no error message. I checked if the data is there and then i throw my own error.

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: Version 1.30.1
  • Database (default: SQLite): postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: linux

hello @Andreas_Pointner

Maybe setting the N8N_PAYLOAD_SIZE_MAX env will help. Environment variables reference | n8n Docs

I’ve already tried that and set the N8N_PAYLOAD_SIZE_MAX=512
But unfortunately that did not change anything.

These are the additional settings that might affect that behavior:

  • N8N_DEFAULT_BINARY_DATA_MODE=filesystem

If i look into the binary_data it looks as if it were cut off at exactly 199M

Does anybody know why there are 2 files with the exact same content?

Hey @Andreas_Pointner,

I would have expected the filesystem and the payload size change to have helped, When you are uploading the data are you going through a reverse proxy or connecting directly to the IP of your n8n instance?

Hey @Jon ,

n8n is working behind traefik as reverse proxy. But this is not the problem since I already tried the upload by bypassing treafik and using the port directly.

The strange thing is that the request header in n8n shows the correct length and if I send other data before the upload that data is shown. If I put it after the upload that data (including the uploaded file) is not visible in the webhook execution.

Hey @Andreas_Pointner,

That is interesting, I just gave it a quick go with a 381MB file and it worked as expected for me.

In the server I am seeing the correct size as well

This is with a payload max of just 50 so it looks like that setting might be unrelated to the upload size.