Schedules at a specific time (cron node)

Hi,

For some reason I just cannot get the workflow to trigger per the schedule in the attached screenshot. I have ensured the time zone is set appropriately.

What am I missing?

Hey @ronykris,

Is your workflow active? Do you have any other trigger nodes in the same workflow?

No, there are no trigger nodes other than cron in the workflow. By the way, it has the start node, but it’s disabled, cannot delete it.

Thanks for answering that. The Start node can’t be deleted, but it doesn’t interfere with the workflow executions, so that is fine. I tried out the Cron node, and it is working as expected for me. Did you check if the workflow is active? Also, did you check the Executions list for any success or failed executions?

yes, I checked. It’s active and it doesn’t show up in execution list. I have other workflows that get triggered by the cron node and those work just fine.

How do I troubleshoot it?

I would start by using one and setting it 5 minutes from now to see what happens.

You can double check the system date / time by using the execute node and running date just to make sure the timezone is working as expected.

1 Like

@jon , thank you!

Thank you for suggesting to run the exec command to validate the current time. This helped!

So, my n8n test environment has been running on wsl and the wsl clock got out of sync after sleep (apparently a known issue). Fixing the wsl clock sync sorted the cron node concern.

2 Likes